Troubleshooting Exchange Integration
From Sense/Net Wiki
- 100%
- 6.0.8
- Enterprise
- Community
Planned
Overview
This page contains guidelines on how to troubleshoot problems emerging with Exchange Integration.
Details
Troubleshooting workflow execution
The executed workflow instances are created in the Workflows System Folder placed under the Content List - the workflows connected to incoming email processing are placed in the MailProcess subfolder under the Workflows System Folder.
- To check why the processing of an incoming email failed: go to the Workflows/MailProcess folder under the Content List, and check the workflow instance with the latest creation date. Browse it, its state should show Aborted and an error message should be displayed in one if its fields. If no error message is displayed, you can check the event log for errors.
Troubleshooting subscriptions of push notifications
Since it is relatively difficult to follow the status of the different subscriptions Sense/Net provides logging for tracing subscriptions and notification messages. Events associated to Exchange integration are logged with the Exchange log category. The following is a list of common messages you can find in the event log:
- Unsubscribe: in case the List Email of a Content List has been cleard or changed; or a subscription occurred over an already active subscription an unsubscribe event will occur. This can occur when a notification message is sent by the Exchange server.
- Message: Exchange unsubscribe: subscriptionId of event and last subscription are different:True, targetemail is empty: True, path: /Root/Sites/Default_Site/workspaces/Document/londondocumentworkspace/Document_Library
- Category: Exchange
- StatusEvent: the Exchange server sends status messages for every subscription periodically with the configured time interval.
- Message: Exchange StatusEvent - Path:/Root/Sites/Default_Site/workspaces/Document/losangelesdocumentworkspace/Document_Library, Email:test@sensenet.com
- Category: Exchange
- NewMailEvent: incoming notification message about new mails are logged
- Message: Exchange NewMailEvent - Path:/Root/Sites/Default_Site/workspaces/Document/londondocumentworkspace/Document_Library, Email:test@sensenet.com, Watermark:AQAAANmwUueV4DJCsiliW6T672zHEkoAAAAAAAE=, SubscriptionId:DgBzbm1haWwwMy5zbi5odRAAAACqKRByoNATQqbUak8/7QDiKAyGxz6Jzgg=
- Category: Exchange
- Subscription service: the execution of the subscription service on startup is logged.
- Message: Exchange subscription service enabled, no subscriptions found.
- Category: Exchange
- Message: Exchange subscription service enabled, running subscriptions (1 found)
- Category: Exchange
- Message: Exchange subscription - Path:/Root/Sites/Default_Site/workspaces/Document/londondocumentworkspace/Document_Library, Email:test@sensenet.com, Watermark:AQAAANmwUueV4DJCsiliW6T672yod00AAAAAAAE=, SubscriptionId:DgBzbm1haWwwMy5zbi5odRAAAADFpn28WsuSRa9bgbQAO1hDmhRWreKNzgg=
- Category: Exchange
Example/Tutorials
This page contains no examples.